sorus.ucoz.ru
Главная
Вход
Регистрация
Вторник, 16.04.2024, 02:03Приветствую Вас Гость | RSS
[Перейти на главную страницу сайта · Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Форум » Драйверы и кодеки » DirectX & NET Framework » Microsoft .NET Framework 4 Final (новейшая версия пакета Microsoft .NET Framework)
Microsoft .NET Framework 4 Final
Сан_СанычДата: Понедельник, 12.04.2010, 22:40 | Сообщение # 1
Admin
Группа: Администраторы
Сообщений: 7259
Статус:
Microsoft .NET Framework 4 - новейшая версия пакета Microsoft .NET Framework. Данный пакет устанавливает среду .NET Framework и связанные с ней файлы, необходимые для запуска приложений, созданных для работы в среде выполнения .NET Framework.

.NET является патентованной технологией корпорации Microsoft. Тем не менее, после заключения договоренности с компанией Novell, технология Mono была признана как реализация .NET на Unix-подобных системах (GNU/Linux, Mac OS X). Однако договорённость касается Novell и клиентов Novell, также технологии ASP.NET, ADO.NET и Windows.Forms не были стандартизированы ECMA/ISO и использование их в Mono находится под угрозой претензий со стороны Microsoft (претензии возможны только в странах, где существуют патенты на программное обеспечение). Mono предоставляет реализацию ASP.NET, ADO.NET и Windows.Forms, но в то же время рекомендует обходить эти API.

Подобно технологии Java, среда разработки .NET создаёт байт-код, предназначенный для исполнения виртуальной машиной. Входной язык этой машины в .NET называется MSIL (Microsoft Intermediate Language), или CIL (Common Intermediate Language, более поздний вариант), или просто IL. Применение байт-кода позволяет получить кроссплатформенность на уровне скомпилированного проекта (в терминах .NET: сборка), а не только на уровне исходного текста, как, например, в С. Перед запуском сборки в среде исполнения CLR байт-код преобразуется встроенным в среду JIT-компилятором (just in time, компиляция на лету) в машинные коды целевого процессора. Также существует возможность скомпилировать сборку в родной (native) код для выбранной платформы с помощью поставляемой вместе с .NET Framework утилиты NGen.exe.

Среды разработки .NET-приложений:
- Microsoft Visual Studio (C#, Visual Basic .NET, Managed C++),
- SharpDevelop,
- MonoDevelop,
- Eclipse,
- Borland Developer Studio (Delphi for .NET, C#),
- PascalABC.NET и т. д.

ОС: Windows all (x32/x64)
Размер: 48,11 Мб

letitbit.net
shareflare.net


 
san12Дата: Понедельник, 12.04.2010, 22:49 | Сообщение # 2
Абитуриент
Группа: Старожилы
Сообщений: 66
Статус:
Спасибо,а 1 ,2 ,3 ,3,5 удалять или как?
 
Сан_СанычДата: Понедельник, 12.04.2010, 22:54 | Сообщение # 3
Admin
Группа: Администраторы
Сообщений: 7259
Статус:
Quote (san12)
Спасибо,а 1 ,2 ,3 ,3,5 удалять или как?

Да без понятия, если честно. У меня например 2, 3 и 3,5 стоят все вместе, конфликтов никаких, я их и не трогаю :o


 
aktuserДата: Вторник, 13.04.2010, 00:47 | Сообщение # 4
Абитуриент
Группа: Старожилы
Сообщений: 60
Статус:
Классика... На сайте разработчиков на момент написания мной этого сообщения ни о каком Final еще нет и речи :o
Зато есть вот такая ссылка : Попробуйте .NET Framework 4. Загрузите Beta 2. beta
Не впервой уже обновления, опережающие офсайты :D
Я пожалуй дождусь пока Мелкософтский вариант подтянется :)
 
AlexДата: Вторник, 13.04.2010, 06:06 | Сообщение # 5
Студент
Группа: Старожилы
Сообщений: 147
Статус:
Quote (san12)
Спасибо,а 1 ,2 ,3 ,3,5 удалять или как?

The bad news is that applications that target the .NET 2.0/3.0/3.5 series will not run on a machine with only .NET 4.0 installed, but at least the user will get a semi-informative error message.

т.е. в переводе, это будет примерно так.
Плохая новость заключается в том, что приложения, ориентированные на среду. NET 2.0/3.0/3.5 серии не будет работать на компьютере, имеющем только. NET 4.0, но по крайней мере, пользователь получит полу-информационный сообщение об ошибке.


Повиснет на шее женщина — и тебе уже легче.
 
Сан_СанычДата: Вторник, 13.04.2010, 07:45 | Сообщение # 6
Admin
Группа: Администраторы
Сообщений: 7259
Статус:
Quote (aktuser)
Не впервой уже обновления, опережающие офсайты

Ага, мы выкладываем, а они у нас тырят :D
Да с оф.сайта все, не раз ведь убеждались в этом...



 
preen75Дата: Вторник, 13.04.2010, 09:30 | Сообщение # 7
Студент
Группа: Старожилы
Сообщений: 100
Статус:
Если на компьютере уже установлена платформа .NET Framework 2.0, дистрибутивный пакет .NET Framework 3.0 и выше,установит только новые компоненты операционной системы Windows . Это позволяет приложениям, основанным на платформе .NET Framework 2.0, работать при установленной платформе .NET Framework 3.0 и выше, при этом миграция или обновление приложений не требуется.
Хотя да на оф сайте MS еще только beta


 
san12Дата: Вторник, 13.04.2010, 10:30 | Сообщение # 8
Абитуриент
Группа: Старожилы
Сообщений: 66
Статус:
Quote (preen75)
Если на компьютере уже установлена платформа .NET Framework 2.0, дистрибутивный пакет .NET Framework 3.0 и выше,установит только новые компоненты операционной системы Windows . Это позволяет приложениям, основанным на платформе .NET Framework 2.0, работать при установленной платформе .NET Framework 3.0 и выше, при этом миграция или обновление приложений не требуется.
Хотя да на оф сайте MS еще только beta
я так понял,если стоит NET Framework 2.0,то можно ставить этот,правильно я понял?
 
preen75Дата: Вторник, 13.04.2010, 10:50 | Сообщение # 9
Студент
Группа: Старожилы
Сообщений: 100
Статус:
Ну вообщем да,так на сайте MS сказанно.вот только если ос клиентская,да и используется дома,то фактически NET Framework ей в большенстве случаев и не требуется.

 
san12Дата: Вторник, 13.04.2010, 11:12 | Сообщение # 10
Абитуриент
Группа: Старожилы
Сообщений: 66
Статус:
Quote (preen75)
Ну вообщем да,так на сайте MS сказанно.вот только если ос клиентская,да и используется дома,то фактически NET Framework ей в большенстве случаев и не требуется.

а .NET Framework 3.0 и .NET Framework 3.5 тогда ненужен? если поставить NET Framework 2 и NET Framework 4
 
preen75Дата: Вторник, 13.04.2010, 12:21 | Сообщение # 11
Студент
Группа: Старожилы
Сообщений: 100
Статус:
san12 можно скачать от сюда Web установщик NET Framework/ Microsoft Web Platform Installer 2.0/он чего не хватает сам добавит Центр загрузки MSDN

в меню после запуска отметить галочками и все,чего не хватает он покажет.
так же можно обновлять и DirectX,тоже есть такой же установщик.

Добавлено (13.04.2010, 12:17)
---------------------------------------------
что бы установить 4 NET Framework надо иметь все предедущие версиии так как он добавит только не достающие звения в этой цепи.

Добавлено (13.04.2010, 12:21)
---------------------------------------------
при использование Web установщика NET Framework/ Microsoft Web Platform Installer 2.0/ в основном меню выбрать Платформы и среды выполнения>настроить >отметить варианты установки


 
san12Дата: Вторник, 13.04.2010, 12:49 | Сообщение # 12
Абитуриент
Группа: Старожилы
Сообщений: 66
Статус:
Quote (preen75)
preen75
СПАСИБО!!!
 
AlexДата: Вторник, 13.04.2010, 12:53 | Сообщение # 13
Студент
Группа: Старожилы
Сообщений: 147
Статус:
Quote (preen75)
Хотя да на оф сайте MS еще только beta

Что то я не видел, чтобы на скачку была beta, в описаниях да, а на скачку стоит Full, а также внутреннея подпсь тоже Full


Повиснет на шее женщина — и тебе уже легче.
 
preen75Дата: Вторник, 13.04.2010, 14:12 | Сообщение # 14
Студент
Группа: Старожилы
Сообщений: 100
Статус:
Да Alex,уже Full,действительно информация была немного старовата про beta,а сегодня не обратил внимание на подпись.

 
MormuxДата: Вторник, 13.04.2010, 18:23 | Сообщение # 15
Бакалавр
Группа: Старожилы
Сообщений: 292
Статус:
Quote (preen75)
Это позволяет приложениям, основанным на платформе .NET Framework 2.0, работать при установленной платформе .NET Framework 3.0 и выше

Quote (san12)
я так понял,если стоит NET Framework 2.0,то можно ставить этот,правильно я понял?

Не совсем. Это означает, что .NET Framework 3.0 и выше включает в свой состав .NET Framework 2.0

Quote (Alex)
приложения, ориентированные на среду. NET 2.0/3.0/3.5 серии не будет работать на компьютере, имеющем только .NET 4.0

То есть предыдущие версии NET 2.0/3.0/3.5 не входят в состав .NET 4.0 и должны быть установлены в системе.


----------------------------------------------
Что бы ни делалось - все к лучшему!
 
AlexДата: Вторник, 13.04.2010, 19:28 | Сообщение # 16
Студент
Группа: Старожилы
Сообщений: 147
Статус:
Quote (Mormux)
То есть предыдущие версии NET 2.0/3.0/3.5 не входят в состав .NET 4.0 и должны быть установлены в системе.

Quote (Alex)
Плохая новость заключается в том, что приложения, ориентированные на среду. NET 2.0/3.0/3.5 серии не будет работать на компьютере, имеющем только. NET 4.0, но по крайней мере, пользователь получит полу-информационный сообщение об ошибке.


Повиснет на шее женщина — и тебе уже легче.
 
aktuserДата: Вторник, 13.04.2010, 22:14 | Сообщение # 17
Абитуриент
Группа: Старожилы
Сообщений: 60
Статус:
Quote (preen75)
Центр загрузки MSDN

По этой ссылке каждому желающему открывается вот такая надпись :
Visual Studio 2010 и бета-выпуск 2 платформы .NET Framework 4 уже доступны.
А при открытии уже этой ссылки натыкаешься вот на это : Загрузите Visual Studio 2010 и .NET Framework 4 Release Candidate
И где тут финал-то? :D
 
Сан_СанычДата: Вторник, 13.04.2010, 22:26 | Сообщение # 18
Admin
Группа: Администраторы
Сообщений: 7259
Статус:
Quote (aktuser)
И где тут финал-то?

Не морочьте голову себе и людям, ссылки в первом сообщении со вчерашнего дня на сайте...


 
aktuserДата: Вторник, 13.04.2010, 22:48 | Сообщение # 19
Абитуриент
Группа: Старожилы
Сообщений: 60
Статус:
Прошу прощения, но я не идиот и нечего из меня его делать! Я прекрасно знаю офсайт .NET Framework и только что тщетно искал там ваш Final. Увы, как бы вам не хотелось, но его там нет. Может вы знаете другой офсайт?! Так поделитесь ссылкой-то.

Добавлено (13.04.2010, 22:48)
---------------------------------------------

Quote (Сан_Саныч)
Да с оф.сайта все, не раз ведь убеждались в этом...

И картинка ваша, увы, битая.
Вот вам свежая ссылочка, полюбопытствуйте : http://msdn.microsoft.com/ru-ru/vstudio/2010.aspx .
 
Сан_СанычДата: Вторник, 13.04.2010, 23:23 | Сообщение # 20
Admin
Группа: Администраторы
Сообщений: 7259
Статус:
Quote (aktuser)
И картинка ваша, увы, битая.

Битая не картинка, а радикал...

Quote (aktuser)
Прошу прощения, но я не идиот и нечего из меня его делать!

Никто Вас идиотом не делает, вчера, когда проверял, нигде ни о бэте, ни о релиз-кандидате в процессе установки или в версии не указывалось. Не верите - проверьте сами. А что качается оф.сайта - кинул ссылку в личку, мне уже проверять повторно не хочется...


 
aktuserДата: Вторник, 13.04.2010, 23:34 | Сообщение # 21
Абитуриент
Группа: Старожилы
Сообщений: 60
Статус:
Quote (Сан_Саныч)
нигде ни о бэте, ни о релиз-кандидате в процессе установки или в версии не указывалось

Да-а, с таким объяснением не поспоришь - просто нет слов...
А на самом сайте этими надписями они просто всех лишних отпугивают, так по-вашему? Мрак...
ap_stenku
 
Сан_СанычДата: Среда, 14.04.2010, 00:00 | Сообщение # 22
Admin
Группа: Администраторы
Сообщений: 7259
Статус:
Quote (aktuser)
А на самом сайте этими надписями они просто всех лишних отпугивают, так по-вашему?

А на самом сайте вчера писали только это
Quote (aktuser)
Зато есть вот такая ссылка : Попробуйте .NET Framework 4. Загрузите Beta 2.

Так что давайте закончим эту демагогию, мне надоел этот спор, вчера Вы указывали, что это бэта и приводили ссылку с оф.сайта, потом убрали, поняв, что это не бэта, сейчас новую дали, завтра мелкософт решит новую страницу открыть и Вы победоносно заявите о своей правоте? Бред!


 
aktuserДата: Среда, 14.04.2010, 00:30 | Сообщение # 23
Абитуриент
Группа: Старожилы
Сообщений: 60
Статус:
Quote (Сан_Саныч)
вчера Вы указывали, что это бэта и приводили ссылку с оф.сайта, потом убрали

Я не приводил ссылку, а лишь указал, что на ней написано.

Quote (Сан_Саныч)
мелкософт решит новую страницу открыть и Вы победоносно заявите о своей правоте? Бред!

Я об этом говорю уже два дня.
Бред - это ваши фантазии насчет финала, которого еще попросту нет на официальном (!) мелкософтском сайте, в чем нетрудно убедиться, просто зайдя на него и прочитав некоторые надписи, сделанные на вполне доступном и понятном русском языке.
Поэтому действительно закончим грустным выводом, что вам-то как раз доказать свою правоту нечем, кроме собственных несостоятельных и ничем особо не подтвержденных амбициозных заявлений (вот где демагогия).
Отсюда и раздражительность, господин админ. Можете удалять коммент, если он задевает ваше самолюбие. И самомнение.
Хиреет сайт помаленьку, мельчает. Жаль.
 
preen75Дата: Среда, 14.04.2010, 11:58 | Сообщение # 24
Студент
Группа: Старожилы
Сообщений: 100
Статус:
уважаемый aktuser,я же обьяснил, что нужно от туда скачать,ну извените если вы по русски не умеете читать,и не можете прочитать все предыдущие комментарии,то это простите говорит о том,что вы не имеете представления о том что тут несете,и я поддерживаю Сан_Саныча в том что это полный бред,кому я давал ссылку,то по моему человек разобрался и скачал что нужно,а ваша поднятая буря в стакане,и беспочвенные обвинения,могут только говорить о вашей воспитанности.а если вы даже не можете на оф сайте MS правельно сорентироваться,то простите о цифровых подписях по моему с вами еще слишком рано рассуждать.
А от таких Voodoo programming как вы, в первую очередь проигрывают только пользователи,и горе тому кто вам доверит свой PC


 
АндроидДата: Понедельник, 19.07.2010, 21:26 | Сообщение # 25
Бакалавр
Группа: Старожилы
Сообщений: 250
Статус:
Большущее спасибо, ибо гаджеты не фунциклируют)))
 
ArletteДата: Воскресенье, 01.08.2010, 08:29 | Сообщение # 26
Академик
Группа: Проверенные
Сообщений: 4646
Статус:
aktuser!

Сия версия вполне рабочая и рентабельная....доказательство можете получить в моем личном тесте в появившейся пока в рецессиве,требующей сие приложение программу ЗДЕСЬ!

И довольно и прекратите придираться ко всем и всему,что вам не нравится и неудобно!...и вы наверное поняли....о чем я!


 
Форум » Драйверы и кодеки » DirectX & NET Framework » Microsoft .NET Framework 4 Final (новейшая версия пакета Microsoft .NET Framework)
  • Страница 1 из 1
  • 1
Поиск:


SORUS 2008-2024 | Sitemap